Site-ul meu nu lucrează cu ajaxcontroltoolkit 3.5 IIS 7.5

Am un site cu asp.net C# atunci când găzduiește local funcționează bine. Când este folosit cu IIS 7.5 și Windows Server 2008, kitul de ajax de control nu funcționează corect. Poate cineva să mă ajute?

Eroare afișată în FireBug:

 NetworkError: 404 Not Found - http://www.acmeinfovision.com/Settings/ClientSalaryHeadSetting.aspx?_TSM_HiddenField_=ctl00_ToolkitScriptManager1_HiddenField&_TSM_CombinedScripts_=%3b%3bAjaxControlToolkit%2c+Version%3d3.5.60501.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d28f01b0e84b6d53e%3aen-US%3a61715ba4-0922-4e75-a2be-d80670612837%3af2c8e708%3ade1feab2%3a720a52bf%3af9cec9bc%3a589eaa30%3aa67c2700%3aab09e3fe%3a87104b7c%3a8613aea7%3a3202a5a2%3abe6fb298%3aaf404b5%3a698129cf%3abb25728f%3a289e72ab"
Client...89e72ab
Sys.Extended is undefined
[Break On This Error]   ...tl00_DropPanel"),"dynamicServicePath":"/Settings/ClientSalaryHeadSetting.aspx","...

Codul paginii principale pare a fi așa

<%@ Master Language="C#" AutoEventWireup="true" CodeBehind="Site.master.cs" Inherits="AcmePayRoll.Site" %>



<meta http-equiv="Page-Enter" content="blendTrans(Duration=0)" /> <meta http-equiv="Page-Exit" content="blendTrans(Duration=0)" /> <title></title> <link href='<%# this.ResolveCSS("~/css/Stylesheet_mini.css")%>' rel='stylesheet'
        type='text/css' />
    <link href='<%# this.ResolveCSS("~/css/ui-Redmond/jquery-ui_mini.css")%>' rel='stylesheet'
        type='text/css' />
    <link href='<%# this.ResolveCSS("~/css/demo_table_jui_mini.css") %>' rel='stylesheet'
        type='text/css' />
    <link href='<%# this.ResolveCSS("~/css/ColVis_mini.css")%>' rel='stylesheet' type='text/css' />
    <link href='<%# this.ResolveCSS("~/css/TableTools_mini.css") %>' rel='stylesheet'
        type='text/css' />
    <link href='<%# this.ResolveCSS("~/css/TableTools_JUI_mini.css")%>' rel='stylesheet'
        type='text/css' />
    <link href='<%# this.ResolveCSS("~/css/ColReorder_mini.css")%>' rel='stylesheet'
        type='text/css' />

    <script src='<%# this.ResolveJS("~/js/jquery-1.7.1.min.js") %>' type='text/javascript'></script>

    <script src='<%# this.ResolveJS("~/js/jquery-ui-1.8.17.custom.min.js") %>' type='text/javascript'></script>

    <script src='<%# this.ResolveJS("~/js/Themeswither/TmemeSwither_mini.js") %>' type='text/javascript'></script>

    <script src='<%# this.ResolveJS("~/js/ScrollableGrid_mini.js") %>' type='text/javascript'></script>

    <script src='<%# this.ResolveJS("~/js/PayrollCommon_mini.js") %>' type='text/javascript'></script>

    <script src='<%# this.ResolveJS("~/js/jquery.table_navigation_mini.js")%>' type='text/javascript'></script>

    <link rel='SHORTCUT ICON' href='<%# this.ResolveUrl("~/Images/Acme-Logo.ICO")%>' />

    <script type="text/javascript">

     document.write("<div id='loading'>
Please Wait...</div>"); $(document).ready(function() { var url='<%# this.ResolveUrl("~/") %>'; AddThemeSwither("ThemeSwither",url); ApplyCommonStyles(); scrlsts(); $("#contentdiv").height($(window).height()); $("#contentdiv").width($(window).width()); }); function check() { var grid = $("<%# grid_clients.ClientID %>"); $(grid).Scrollable({ ScrollHeight: 70 }); } function help_click(e) { var helpurl= $(e.parentNode).find("input[type='hidden']"); var val=helpurl.val(); if(val!="") { window.open(val,'win'); } } </script>
</head>
<body style="margin: 0; background-color: #FDF8FF;" >
    <div style="vertical-align: top; width: 100%; height: 144px; top: 0; margin: 0;">
        <form id="form1" runat="server">
        <div id="contentdiv" style="width: 100%; border-bottom-color: Black">
            
            
            <%--
            --%>
            <table width="100%" style="height: 100%" border="0" cellpadding="0" cellspacing="0">
                <tr class="ui-state-hover" style="vertical-align: top; height: 8%">
                    <td style="width: 20%">
                        <div id="ThemeSwither">
                        </div>
                        
                    </td>
                    <td colspan="2" style="text-align: right">
                        <table width="100%">
                            <tr style="vertical-align: top">
                                <td colspan="2" align="right">
                                    
                                </td>
                                <td style="width: 10%; vertical-align: top" align="right">
                                    SignOut
                                    <input type="hidden" id="hidden_help_url" runat="server" />
                                    
                                </td>
                            </tr>
                            <tr>
                                <td align="center">
                                    
                                        
                                            
                                            
                                        
                                    
                                </td>
                                <td>
                                     
                                </td>
                                <td align="right">
                                    <table>
                                        <tr>
                                            <td>
                                                
                                                    
                                                        
                                                        
                                                    
                                                
                                            </td>
                                            <td>
                                                
                                                
                                                
                                                    
                                                        
                                                        
                                                        
                                                    
                                                
                                            </td>
                                        </tr>
                                    </table>
                                </td>
                            </tr>
                        </table>
                    </td>
                </tr>
                <tr>
                    <td colspan="3">
                        <div>
                            
                            
                        </div>
                    </td>
                </tr>
                <tr style="height: 83%; vertical-align: top">
                    <td colspan="3">
                        <div class="ui-widget-header" id="nav-menu">
                            
                            
                        </div>
                        <div style="text-align: center" class="ui-state-hover">
                            
                        </div>
                        <div style="border-left-width: 30px; border-left-style: solid; border-left-color: #FDF8FF;
                           
0
întrebarea dvs. este prea complicată și nu vă concentrați asupra problemei reale, mai mult dați-ne și pagina de html redată pentru a vedea ce anume faceți pe pagină. De asemenea, am găsit niște bug-uri pe JavaScript și design rău. Parerea lui complică pagina, când începe să nu funcționeze? pentru că sigur că nu ai reușit să faci asta.
adăugat autor Aristos, sursa
încă o dată, aceasta este pagina principală, care este pagina de fapt care utilizează această pagină care a avut problema?
adăugat autor Aristos, sursa
Ai postat aceeași întrebare de 3 ori ....
adăugat autor Aristos, sursa
adăugat autor Peter, sursa

1 răspunsuri

Sys.Extended is undefined
but it is working on local IIS 6, IIS 7 IIS 7.5

Din toate întrebările care sunt la fel cu acest concluzionăm că ați uitat să includeți AjaxControlToolkit.dll în directorul dvs. bin.

Dacă ați inclus, atunci nu ați înregistrat corect pe web.config pe serverul diferit.

0
adăugat