Mac + RStudio: Actualizați hardware-ul sau păstrați software-ul degradat?

Other R-users may well agree that the RStudio IDE has been an extremely effective way to increase productivity. But, with the release of RStudio 0.96.122, neither 32-bit Macs nor OSX < 10.6 (Snow Leopard) are supported. I run OSX 10.6, but on a 32-bit Intel Mac; hence, my choices are

  1. Acceptați că aceasta va fi ultima versiune funcțională a sistemului meu și va face față limitărilor sale.
  2. Plângeți dezvoltatorii - prefer să nu.
  3. Cumpărați hardware nou, scump, adică un nou Mac.
  4. Opriți utilizarea R și/sau RStudio

Deci, întrebarea mea este: În ce moment este înțelept să faceți upgrade hardware mai degrabă decât să păstrați o versiune anterioară de software, cum ar fi RStudio ? Este de 64 de biți atât de important pentru utilizatorii "normali"?

În mod clar RStudio este dezvoltat în mod activ de către niște programatori cu adevărat inteligenți, dar macar, Mac-urile sunt scumpe.

1
Puteti Parallels + Windows + RStudio mai recente?
adăugat autor spender, sursa
Ai putea șterge OSX și instala Linux (cu aceeași problemă, sunt tentat să fac asta)
adăugat autor baptiste, sursa
Având o interfață directă cu arhivele Git este destul de frumos.
adăugat autor Andy Barbour, sursa
RStudio este foarte drăguță, dar ... face ceva care, de ex. Emacs + ESS nu/nu poate?
adăugat autor Ben Bolker, sursa

1 răspunsuri

În prezent mă confrunt cu aceeași problemă. Cred că ați putea instalați R pe Amazon EC2 >. O să încerc asta în zilele următoare. Voi reveni aici pentru a întreba cum să folosiți un proxy pentru a asigura rezultatul.

0
adăugat