instalați JRE în heroku

I got this error in running heroku run rake sunspot:solr:run

rake aborted!
You need a Java Runtime Environment to run the Solr server

există o modalitate de a putea instala jre în heroku?

0

1 răspunsuri

Nu puteți instala JRE pe Heroku și, prin urmare, nu puteți rula Solr de la un lucrător din Heroku.

Dacă doriți Solr în Heroku, va trebui să utilizați addon-ul Websolr sau să porniți un EC2 server și rulați-vă propria copie a lui Solr de acolo.

0
adăugat
trist să audă. deși am încercat să ruleze propriul meu server pentru Solr, nu a funcționat. poate din cauza problemelor de reindexare.
adăugat autor Jude Calimbas, sursa
Nu oferă Heroku limbi bazate pe JVM acum?
adăugat autor echristopherson, sursa